I recently changed from Zone Alarm Suite to their "Extreme" suite. Since then PT3 hasn't been able to connect to the database. I ran into this problem years ago with PT2 but darned if I can remember the solution. Can you give me a hand here?
Here is some log information that might help. I have deleted duplicate entries in the log file but made notes of what I deleted for the sake of space on the forum.
log file starts:
2009-05-11 08:52:57 PDT LOG: database system was shut down at 2009-05-11 00:27:27 PDT
2009-05-11 08:52:57 PDT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2009-05-11 08:52:57 PDT FATAL: the database system is starting up
2009-05-11 08:52:58 PDT LOG: database system is ready to accept connections
2009-05-11 08:52:58 PDT LOG: autovacuum launcher started
2009-05-11 08:52:59 PDT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
FATAL: could not reattach to shared memory (key=1804, addr=016E0000): 487
2009-05-11 08:55:18 PDT WARNING: worker took too long to start; cancelled
repeated 10 more times
attempted to start PT3
FATAL: could not reattach to shared memory (key=1804, addr=016E0000): 487
2009-05-11 08:55:18 PDT WARNING: worker took too long to start; cancelled
(repeated 23 more times)
2009-05-11 09:07:18 PDT WARNING: worker took too long to start; cancelled
FATAL: could not reattach to shared memory (key=1804, addr=016E0000): 487
(repeated 23 more times)
2009-05-11 09:08:18 PDT WARNING: worker took too long to start; cancelled
FATAL: could not reattach to shared memory (key=1804, addr=016E0000): 487
PT3 cannot attach so...
At this point I "stopped service", "reloaded config" and "started service". (from experience I've found that just stopping and restarting doesn't work.)
2009-05-11 09:08:20 PDT LOG: received fast shutdown request
2009-05-11 09:08:20 PDT LOG: aborting any active transactions
2009-05-11 09:08:20 PDT LOG: autovacuum launcher shutting down
2009-05-11 09:08:20 PDT LOG: shutting down
2009-05-11 09:08:20 PDT LOG: database system is shut down
Next is log of restart after PT3 is running. PT3 attaches and runs OK.
2009-05-11 09:08:32 PDT LOG: database system was shut down at 2009-05-11 09:08:20 PDT
2009-05-11 09:08:32 PDT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2009-05-11 09:08:32 PDT FATAL: the database system is starting up
2009-05-11 09:08:33 PDT LOG: database system is ready to accept connections
2009-05-11 09:08:33 PDT LOG: autovacuum launcher started
2009-05-11 09:08:33 PDT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2009-05-11 09:09:27 PDT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2009-05-11 09:09:37 PDT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
end of log file
It would appear,to me anyway, that the cause of the failure to restart is caused by the debugger? This could possibly be because of the new Firewall/Virus/Spyware. If so, do I have to find this DLL and give it permission to run?
